Olilo - CityFibre Outage | Birmingham – Incident details

All systems operational

CityFibre Outage | Birmingham

Resolved
Partial outage 10 %
Started 29 days agoLasted 1 day

Affected

CityFibre

Partial outage from 7:39 PM to 8:00 PM

Updates
  • Resolved
    UTC
    Resolved
    This incident has been resolved.
  • Monitoring
    UTC
    Monitoring

    Service has now been successfully restored following intervention from the onsite FLM engineer. The issue was identified as being caused by elevated temperatures, which resulted in equipment impact. Once conditions stabilised and the FLM completed the necessary checks, services returned to normal operation. We will continue to monitor the situation closely to ensure ongoing stability and will provide further updates if required.

    Next update at: 07:30 26/06/2026

  • Investigating
    UTC
    Investigating

    CityFibre are currently investigating an issue affecting some customers in the Birmingham area.

    Their Major Incident process has been invoked and their team are working to identify the root cause. At this stage, a CityFibre field engineer has been dispatched to site with an ETA of 20:30.

    Next update: 21:30 on 25/06/2026